Tipologia News: Articoli

Calendario corsi MikroTik 2017

Di seguito i corsi MikroTik programmati per quest’anno:

 

Per ulteriori informazioni:

www.mikrotik-training.it

info@infranetconsulting.it

Corsi di formazione e certificazioni MikroTik a domicilio

Con la presenza in sede cliente di un Trainer certificato MikroTik è possibile organizzare corsi di certificazione MikroTik su tutte e sette le certificazioni ufficiali MikroTik.
Il servizio comprende la presenza in sede del trainer, il relativo corso di certificazione e l’esame on-line sui training server MikroTik che permette, dopo il superamento della prova, l’acquisizione della certificazione ufficiale.

 

Un esempio di un pacchetto di 2 giorni:
mtcnamtcre


Corso di due giorni full immersion a domicilio per conseguire le seguenti certificazioni:

 +

 

Al termine del corso ciascun partecipante potrà sostenere online, presso il Training Server MikroTik, gli esami di certificazione.
Soltanto con il superamento degli esami sarà possibile ottenere i Certificati ufficiali.

Per informazioni: info@infranetconsulting.it

MPLS ( Multi Protocol Label Switching )

L’ MPLS è una tecnologia ad alte prestazioni per l’istradamento di pacchetti Ip attraverso un infrastruttura di rete.
Basicamente, l’ MPLS associa a ciascun pacchetto un identificativo di lunghezza fissa, detto Label, tramite i quali gli apparati ri rete riescono ad effettuare un istradamento dei flussi di traffico altamente prestante.
La tecnologia MPLS è considerata come un protocollo di livello 2 e mezzo, in quanto sfrutta tecnologie del livello Data Link ( layer 2 ) e permette ai routers di instradare un pacchetto senza andare ad interrogare le proprie tabelle di routing, saltando quindi il livello Ip ( layer 3 ).
Semplificando concettualmente questa tecnologia, possiamo dire l’istradamento del flusso dati è più veloce del livello 3, in quanto vengono ignorati i processi di routing per far giungere un pacchetto a destinazione.
Per quanto riguarda l’implementazione del Multi Protocol Label Switching, è necessario avere la propria infrastruttura routata, ovvero avere un protocollo di routing dinamico sulla propria rete, per poi implementare l’ MPLS nei routers.
Nello scenario classico di un Isp / Wisp come protocollo di routing dinamico interno, si utilizza
l’ OSPF ( Open Shortest Path First ) per poi implementarci sopra l’ MPLS che garantisce un incremento prestazionale di un buon 30%.
Un ulteriore passo avanti per quanto riguarda l’ottimizzazione tecnica di una infrastruttura consiste nell’aggiungere dei tunnel VPLS dove far passare l’autenticazione degli utenti, ma di questo parleremo in seguito.

Per ulteriori informazioni riguardo l’ implementazione sulla propria rete del protocollo di routing dinamico OSPF corredato dalla tecnologia MPLS:

 info@infranetconsulting.it

Internet Exchange Point

Cos’è un Internet Exchange Point?
Wikipedia ci da una ottima definizione:
Un Internet Exchange Point (IXP), o punto di interscambio, detto anche NAP (Network Access Point) è un’infrastruttura fisica che permette a diversi Internet Service Provider di scambiare traffico Internet fra loro, interconnettendo i propri Autonomous System attraverso accordi di peering.
Questo permette agli ISP di risparmiare una parte della banda che comprano dai loro upstream provider, e di guadagnare in efficienza e in affidabilità.

Lo scopo principale di un IXP è di permettere alle reti degli ISP di interconnettersi fra di loro direttamente, attraverso il punto di interscambio, piuttosto che far passare il traffico attraverso uno o più provider esterni. I vantaggi sono i seguenti:

  • Velocità: la connessione diretta fra due Autonomous System, senza passaggi intermedi, minimizza il tempo di latenza dei pacchetti nell’attraversarli.
  • Efficienza: la diversificazione delle connessioni che un operatore Internet ha verso il resto degli ISP gli permette di evitare un single point of failure, ovvero un oscuramento da Internet qualora l’unico collegamento (quello con l’upstream provider) venisse meno, aumentando così la ridondanza dell’infrastruttura di rete.
  • Costo: il costo globale di afferenza ad un IXP (inclusi i costi di setup del collegamento) è generalmente molto minore rispetto al costo del transito Internet. Gli accordi di peering tra i partecipanti ad un punto di interscambio sono nella maggior parte dei casi effettuati a titolo gratuito.

Ip -> Cloud RouterOS 6.14

Nuova funzione con il firmware 6.14, IP -> CLOUD
che permette di raggiungere il device Mikrotik anche se ha un ip pubblico dinamico.
di seguito il wiki che spiega il funzionamento in dettaglio:

DynDns & Mikrotik

Spesso abbiamo la necessità di raggiungere un device da remoto e non sempre il nostro apparato ha un ip pubblico statico, pensate ad esempio ad un access point dietro una adsl con ip pubblico dinamico.

Ecco che ci viene in aiuto il servizio (gratuito per un host) DynDns, http://dyndns.it/.
Registriamoci quindi al servizio ed andiamo a configurare l’apparato Mikrotik.

Ecco lo script da inserire nel vostro mikrotik per renderlo raggiungibile a prescindere dall’ip pubblico che gi viene assegnato:
/system script
add name=dyndns policy=reboot,read,write,policy,test,password,sniff,sensitive source=”# Set needed variablesr
    n:local username “YOURUSERNAME”r
    n:local password “YOURPASSWORD”r
    n:global hostname “YOURDYNDNSNAME”r
    nr
    n:global dyndnsForcer
    n:global previousIPr
    n:global currentIPr
    nr
    n# print some debug infor
    n# :log info (“UpdateDynDNS: username = $username”)r
    n# :log info (“UpdateDynDNS: password = $password”)r
    n# :log info (“UpdateDynDNS: hostname = $hostname”)r
    n# :log info (“UpdateDynDNS: previousIP = $previousIP”)r
    nr
    n# get the current IP address from the internet (in case of double-nat)r
    n/tool fetch mode=http address=”checkip.dyndns.org” src-path=”/” dst-path=”/dyndns.checkip.html”r
    n:local result [/file get dyndns.checkip.html contents]r
    nr
    n# parse the current IP resultr
    n:local resultLen [:len $result]r
    n:local startLoc [:find $result “: ” -1]r
    n:set startLoc ($startLoc + 2)r
    n:local endLoc [:find $result “</body>” -1]r
    n:global currentIP [:pick $result $startLoc $endLoc]r
    n# :log info “UpdateDynDNS: currentIP = $currentIP”r
    nr
    n# Remove the # on next line to force an update every single time – useful for debugging,r
    n#  but you could end up getting blacklisted by DynDNS!r
    nr
    n#:set dyndnsForce truer
    nr
    n# Determine if dyndns update is neededr
    n# more dyndns updater request details http://www.dyndns.com/developers/specs/syntax.htmlr
    n:if (($currentIP != $previousIP) || ($dyndnsForce = true)) do={r
    n    :set dyndnsForce falser
    n    /tool fetch user=$username password=$password mode=http address=”members.dyndns.org” \r
    n       src-path=”/nic/update?hostname=$hostname&myip=$currentIP” dst-path=”/dyndns.txt”r
    n    :local result [/file get dyndns.txt contents]r
    n    :log info (“UpdateDynDNS: Dyndns update needed”)r
    n    :log info (“UpdateDynDNS: Dyndns Update Result: “.$result)r
    n    :put (“Dyndns Update Result: “.$result)r
    n} else={r
    n#    :log info (“UpdateDynDNS: No dyndns update needed”)r
    n}r
    nr
    n:set previousIP $currentIP”


Modificate adeguatamente i seguenti valori con le vostre credenziali DynDns e con il vostro url creato in fase di configurazione di un host nel portale DynDns:

    n:local username “YOURUSERNAME”r
    n:local password “YOURPASSWORD”r
    n:global hostname “YOURDYNDNSNAME”r

Creaiamo poi uno scheduler che automatizzerà l’esecuzione dello script:
/system scheduler
add disabled=no interval=10m name=”DynDNS” on-event=”DynDNS” policy=
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api start-time=startup
Buon divertimento e buona Pasqua!!

Backup e Export Configurazione Mikrotik automaticamente su Google Drive

Ciao a tutti!
Di seguito come eseguire automaticamente il backup e l’export della configurazione di un apparato Mikrotik e caricarlo su Google Drive:
Script:
#### Modificate questi valori in base alle vostre esigenze ####

#La vostra mail nella quale volete riceve i backup
:local toemail “xxxxx@esempio.it”

#La mail dalla quale riceve i backup
:local fromemail “xxxxx@backup.it”

#Il mail server in formato IP
:local emailserver “5.144.164.174”

############## Non modificare nulla qui sotto ##############

:local sysname [/system identity get name]
:local textfilename
:local backupfilename
:local time [/system clock get time]
:local date [/system clock get date]
:local newdate “”;
:for i from=0 to=([:len $date]-1) do={ :local tmp [:pick $date $i];
:if ($tmp !=”/”) do={ :set newdate “$newdate$tmp” }
:if ($tmp =”/”) do={}
}
#check for spaces in system identity to replace with underscores
:if ([:find $sysname ” “] !=0) do={
:local name $sysname;
:local newname “”;
:for i from=0 to=([:len $name]-1) do={ :local tmp [:pick $name $i];
:if ($tmp !=” “) do={ :set newname “$newname$tmp” }
:if ($tmp =” “) do={ :set newname “$newname_” }
}
:set sysname $newname;
}
:set textfilename ($”newdate” . “-” . $”sysname” . “.rsc”)
:set backupfilename ($”newdate” . “-” . $”sysname” . “.backup”)
:execute [/export file=$”textfilename”]
:execute [/system backup save name=$”backupfilename”]
#Allow time for export to complete
:delay 2s

#email copies
:log info “Emailing backups”
/tool e-mail send to=xxxxx@esempio.it from=xxxxx@backup.it

server=5.144.164.174 port=587 subject=”[Config Backup] $sysname $time” file=$”textfilename”
#Send as different subjects to force GMail to treat as new message thread.
:local time [/system clock get time]
/tool e-mail send to=xxxxx@esempio.it from=xxxxx@backup.it
server=5.144.164.174 port=587 subject=”[Config Backup] $sysname $time” file=$”backupfilename”

#Allow time to send
:delay 10s

#delete copies
/file remove $textfilename
/file remove $backupfilename

Impostare anche l’account email da Tools -> Email.

Operazioni su Gmail:

 
Entriamo nel nostro account Gmail e creiamo una etichetta chiamata “RBackup” e un altra chiamata “RBackup Saved” per i files che andrà a creare lo script.
Creiamo un filtro in Gmail per tutte le mail provenienti da  xxxxx@backup.it destinate a xxxxx@esempio.it dove l’oggetto contiene “[Config Backup]” e spostatela nella nuova “RBackup” cartella/etichetta.

Operazioni su GoogleDrive:

Poi entriamo nel nostro Google Drive e creiamo una cartelle nella root directory chiamata “Router Backups”.
Copiamo poi la tabella seguente nella nostra cartella tramite il seguente link: spreadsheet provided

Autorizzate e fate partire l’app dal menù che vi comparirà una volta copiato il file Google.

Scheduler:

L’ultimo passo è assicurarsi ci sia uno scheduler per avere lo script che esegue le sue operazioni ogni notte, settimana, mese o quando volete eseguire i vostri backup:

/system scheduler
add interval=1d name=daily-backup on-event="/system script run backup-and-email" policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api start-date=jan/01/2014 start-time=04:00:00


Il risultato finale:
Buon divertimento!!!

Firmare Mikrotik 6.11 released: novità: Controlled Access Points system

Finalmente è uscito il tanto atteso nuovo firmware Mikrotik!!

6.11

che introduce la funzionalità di 

CONTROLLER ACCESS POINT: CAPs Manager

per info iniziali:

http://wiki.mikrotik.com/wiki/Manual:CAPs_Manager

Vediamo se oggi avrò il tempo di giocarci e testarlo un po’..
Appena ho news vi aggiornerò!

Upgrading RouterOS

Ottimo:
 If you are already running RouterOS, upgrading to the latest version is simple.
Just one click, and RouterOS will find the latest version, show you the changelog,
and offer to upgrade.
You can do this from Winbox, console, Webfig or QuickSet. Simply click 
“Check for updates”
in QuickSet, Webfig or Winbox packages menu. 
 http://www.mikrotik.com/download

RIPE vs ISP/WISP

Il RIPE è uno dei cinque Regional Internet Registry (RIR) esistenti in ambito IANA con delega per l’assegnazione degli indirizzamenti IPv4 ed IPv6: il RIPE NCC si occupa delle assegnazioni per l’Europa, il Medio Oriente e l’Asia centrale (fino ad aprile del 2005, si occupava – come RIR – anche dei paesi del nordafrica che sono passati successivamente, insieme al resto dei paesi africani, sotto la gestione dell’AfriNIC).
 Il RIPE NCC è un’organizzazione indipendente e non-profit, detenuta dai propri membri (si tratta principalmente di Internet Service Provider, organizzazioni nell’ambito delle telecomunicazioni e grandi aziende delle nazioni appartenenti alle regioni amministrate dal RIPE NCC) la cui sede si trova ad Amsterdam.
Il RIPE NCC opera sotto la legge olandese e le attività dello stesso sono supervisionate da un Consiglio di amministrazione i cui membri sono eletti con mandato triennale.
Le normative del RIPE NCC vengono stabilite nell’ambito dei working groups del RIPE.
Uno dei servizi più noti, forniti anche dal RIPE NCC per la regione di sua competenza, è quello di IP lookup: il RIPE Whois Database.
Fondamentale è l’iscrizione al Ripe in quanto si potranno ottenere molti vantaggi in termini di ottenimento di indirizzi IP per la vostra infrastruttura di rete o numero di AS.
Contattatemi per saperne di più!!!!